Кремень А Реклама
Кремень АМ Реклама

Странные команды перед стартовым кодом в cura

Андрей_CE3
Идет загрузка
Загрузка
10.06.2024
655
33
Вопросы и ответы
Статья относится к принтерам:
Creality Ender-3 S1 Pro

Всем привет. Переустанавливал недавно винду и скачал заново cura последней версии (5.7.2). Обнаружил, что она странно работает с нагревом стола и сопла. Вот стартовый код, который прописан в настройках:

; Ender 3 S1 Pro Start G-code

; M413 S0 ; Disable power loss recovery

G92 E0 ; Reset Extruder

M140 S{material_bed_temperature} ; Нагреть стол до заданной температуры

M104 S{material_print_temperature} ; Нагреть хотэнд до заданной температуры

M190 S{material_bed_temperature} ; Ожидать нагрева стола

M109 S{material_print_temperature} ; Ожидать нагрева хотэнда

G28 ; Home all axes

G92 E0 ; Reset Extruder

BED_MESH_PROFILE LOAD="default"

Но при генерации кода в файле получается вот так:

M104 S215

M105

M109 S215

M82 ;absolute extrusion mode

; Ender 3 S1 Pro Start G-code

; M413 S0 ; Disable power loss recovery

G92 E0 ; Reset Extruder

M140 S55.0 ; Нагреть стол до заданной температуры

M104 S215.0 ; Нагреть хотэнд до заданной температуры

M190 S55.0 ; Ожидать нагрева стола

M109 S215.0 ; Ожидать нагрева хотэнда

G28 ; Home all axes

G92 E0 ; Reset Extruder

BED_MESH_PROFILE LOAD="default"

G92 E0

G92 E0

G1 F2400 E-1

То есть сначала происходит нагрев сопла, а потом стола по очереди. Я хочу, чтобы они грелись одновременно и специально вставил для этого стартовый код, но из-за команды M109 перед ним всё идет наперекосяк. Как можно куру вразумить? Может, за это какая-то настройка отвечает, которую я не вижу?

Профиль переносил свой старый, принтер на клипере, Ender s1 pro.

Ответы на вопросы