Выдает ошибку.

AlekS
Идет загрузка
Загрузка
04.05.2021
113
6
Вопросы и ответы

При запуске Visual Studio Code выдает ошибку... не могу  найти в чем дело...(((

Питон стоит...винда 7... все работало полмесяца назад...

Ответы на вопросы

Ответы

04.05.2021 в 15:08
0

Питон у вас должен быть уст. в самом VScode. 

Platform IO там же работает к сожалению по разному. От обновления к обновлению.

Поэтому с вашей проблемой лучше обратится к ним на форум.

04.05.2021 в 15:19
1

В самом VScode питон не встанет, т.к. пытается установить версию, не работающую на Win7. Питон версий 3.8.х для Win7 ставится отдельно и прекрасно подцепляется. Я бы на месте автора попробовал переустановить питон свежим релизом 3.8.10.

04.05.2021 в 16:35
0

Спсибо, Алексей. Поставил ПитонА 3.8.10, старый "выбил"... скачал на всяк) случай  и  VScode последний но не ставил... После пуска долго висел так...

Потом поехал) Бин сделал, но все ровно ошибку пишет...

Понял так что VScode пытался установить сам.. но для 8.1 и выше? Для 7 только ручками теперь?

04.05.2021 в 16:41
0

Ну он будет пробовать при установке ставить питон, вроде как, но если уже стоит, то потормозит и пойдет дальше. У меня, по-моему,так было. Но для Win7 после выхода питона 3.9 только ручками теперь. Я ставил VScode, потом питон, потом PlatformIO.
Но у вас на питон и не ругается вроде, а на отсутствие определения глобальной переменной upload_port.

04.05.2021 в 17:01
0

Да, с портом разобрался.

Понял так что Винда 7 умерла не только в плане поддержки...(( Жаль.

Спасибо. 

04.05.2021 в 16:56
1

У вас ругается так как не нашел куда грузить прошивку, а так компиляция прошла успешно

Для написания комментариев, пожалуйста, авторизуйтесь.

Читайте в блогах

Кот и рыба

Авто Податчик Припоя (Жизни уже не будет прежней)

Пронзающий пространство (фантастическая повесть) Продолжение 14

Ошибка autotune failed temperature too high при настройки PID, переназначение портов в MARLIN для термистора.

Посыпались ремни - не страшно, есть ещё пластик и дихлорметан.

Орден Славы