Комп не подключается к Mega 2560

tropkin1@mail.ru
Идет загрузка
Загрузка
26.01.2021
243
17
Вопросы и ответы

Здравствуйте форумчане.Имеется платка mega 2560, поставил я ее на 3д принтер и на работающем решил поправить радиатор драйвера( близко был к контактам ) и по факту только сделал хуже, а именно докоснулся самим радиатором до некоторых контактов драйвера a4988. После этого комп перестал подключаться к плате, но порт активным видит!! Но передача данных не идет. Можно как - то починить это дело или микроконтроллер сдох, всё?

Ответы на вопросы

Ответы

26.01.2021 в 16:38
1

попробуйте еще раз, нужно выяснить что с чем коротнуло. Тогда и ясней станет. но раз не подключается значит чёто прогорело.

Сколько раз писано - на работающем девайсе металлическими частями не шурудить!

Отключи - и тыкай сколько нужно.

26.01.2021 в 18:06
0

Бывает такое, что подключится, а потом бац и все. Не работает.

26.01.2021 в 17:13
0

Комп видит только микросхему порта. Сам микроконтроллер умер. Для большей уверенности в этом, нужно снять RAMPS и попробовать подцепить к компьютеру одну мегу и попробовать хотя бы прошить. Но думаю занятие бестолковое. МК 99.9% мёртв.

Ищите в этом и положительные стороны. Вместо меги 2560 купите уже 32 битную версию.

26.01.2021 в 18:07
0

Она то подключается, то нет.

Сначала не подключалась, я отцепил от рампса и она подключилась.

Потом поставил обратно - тоже работает. Перепрошил даже. Потом бац и опять на работает...

26.01.2021 в 18:10
0

То есть получается, что Вы после инцидента с замыканием, какое то время работали и уже потом она отказала? Всё правильно?

Что бы получить правильный ответ, нужно задать правильно вопрос и подробно всё описать. Телепатов здесь нет.

26.01.2021 в 19:27
0

Описал как есть.

После замыкания она полностью работала и принимала все команды от инкодера( с экрана управлял и движками всеми и даже тот драйвер сам работал), но к компу после она сначала не подключалась. Комп ее видит, но пишет,что порт закрыт.

Позже резко стал ее видеть, я опять подключился, перепрошил на всякий случай и потом через пару минут опять порт закрыт. И так постоянно.

26.01.2021 в 20:00
0

Так дело скорее всего не в плате и не в RAMPS, а в системе. Чудес то не бывает. В электронике если то работает, то не работает - смотри контакты. А если уж сгорело, то сгорело. Не бывает, что сгорело чуть-чуть. Контакта нет или там где он должен быть, или он есть где его быть не должно (замыкание). Но судя по последнему описанию, смотрите в сторону операционки. Возьмите у кого нибудь ноут на пол часа и к нему попробуйте подцепить.

26.01.2021 в 20:42
0

Вот прямо щас работает. 6 раз переподключал, работает.

Замкнул контакты: mS1-2-3, reset, Sleep ещё возможно (докоснлся чуть).

Но все отлично работает через обычный инкодер! Двигатели двигаются, все работает ..

Но подключается к ПК через раз будто.

С самим рампсом ниче не могло быть?

26.01.2021 в 23:32
0

проверь диод,
скорее всего его пробило и контроллер получает обратку от блока питания через стабилизатор

27.01.2021 в 08:45
0

я питание разделил 

28.01.2021 в 01:26
0

значит какой то из драйверов шагового даигателя сгорел

26.01.2021 в 21:00
0

RAMPS - это только удобная плата разводки от микроконтроллера к внешним устройствам. Там из электроники только мосфеты для нагревателей и конденсаторы для обвязки. За подключение к компьютеру RAMPS ну никак не отвечает.

За подключение к компьютеру отвечает сама плата MEGA 2560.

Обратите внимание на блок USB Communication Unit. Плата MEGA 2560 простая как три копейки.


26.01.2021 в 21:03
0

Если компьютер видит MEGA 2560, но порт занят, то дело или в кабеле или в настройке порта. Попробуйте переключить на другой порт и указать его в программе. Опять же. Когда Вы перепрошивали плату, то какую скорость порта указали? Для MEGA 2560 должно быть не больше 115200.

26.01.2021 в 22:52
0

Указал 250000

Такой вопрос ещё: валяется старая плата ramps 1.6 на ней замкнуты были контакты gnd и vin, на пол секунды буквально.

После она работала в принципе, но всю локигу не проверял, но экструдер вращался ток в одну сторону.

Вообще может чето с ней случиться из-за этого? Вроде как работала....

Хочу узнать варианты последствий 

26.01.2021 в 22:52

Комментарий удалён

26.01.2021 в 22:52

Комментарий удалён

26.01.2021 в 23:17
0

Зачем столько раз одно и тоже сообщение плодить? Я вроде не даун.

То, что Вы указали 250000 и делает Вашу плату недоступной с порта. MEGA 2560 выше 115200 скорость не поддерживает. Перепрошивайте. Прошивка всё равно идёт на скорости 38400 или 57600.

От замыкания gnd и vin на ramps 1.6 ничего сгореть не может. Повторяюсь. Это просто плата расширения. Удобная разводка с микроконтроллера до драйверов, мосфетов, датчиков и экрана. Там просто нечему сгорать. Можете смело пользоваться. А направление вращения экструдера указывается в прошивке или меняется переворотом кабеля экструдера и никак не может зависеть от замыкания.

Я не понимаю. Ведь логически Вы мыслить умеете. НИКОГАДА нельзя что либо делать на ходу при включённой электронике!

И удалите дублированные сообщения...

26.01.2021 в 23:33
0

Дублировались само, я не специально это делал. Да я просто решил поправить радиатор, он больно близко к этим контактам был(2х сторонний скочт) , побоялся и оперативно решил исправить.

26.01.2021 в 23:39
0

Я тоже помню, как в двенадцать лет собирал цветомузыку и мне показалось, что на одной из ламп провода отошли. А там 220. Решил поправить на включенной. Глазом не успел моргнуть как руки завернуло. Хорошо отец рядом был, провода вырвал..

Век живи и век учись. Для Вас этот опыт обошёлся без потерь. Не всем так везёт.

Для написания комментариев, пожалуйста, авторизуйтесь.

Читайте в блогах

Arnold Schwarzenegger на Elegoo Saturn Mono X

Обработка pla пластика

Anycubic Predator (D) + SKR 1.4(TURBO) + Klipper + Raspberry Pi (Zero W) + 12864 RepRap LCD

Простой ключ для пробок АКБ

Dr. Raymond Stantz и вся команда

Реорганизация кабеля стола Ender 3