Странное поведение оси Z

Подписаться на 3Dtoday
PoguoH
Идет загрузка
Загрузка
18 Июля 2018
453
6
Вопросы и Ответы
И так, если коротко, то при первом поднятии оси Z она поднимается, но опустить потом с первого нажатия не получается(как бы не реагирует), а уже со второго нажатия можно опустить на шаг.
Постараюсь поподробней. Принтер Anet E10. Запускаю печать высотой слоя 0.1(стол выставлен) начинается печать с правильной высотой, но только стоит принтеру сделать ретракт(настроен с подъемом 0.2), то он не возвращает сопло на высоту печати перед ретрактом, а остается на высоте настроеного подъема. Последующие ретракты работают исправно.
Может быть кто-то знает в чем может быть проблема. Грешу на прошивку так как прошивка стоит не родная, а с сылка предоставленная "effernity"(за что большое спасибо). Может быть кто-то знает где, чего там подкрутить?
Ответы на вопрос

Ответы

19.07.18 в 07:11
печатает на Ultimaker 3 Extended
0
как бы не реагирует
Вот это как раз ключевой момент. Если двигатель крутит, а ось не двигается, то скорее всего у вас механический люфт. А если двигатель не крутит, то проблема скорее программно-электрическая.
19.07.18 в 07:17
0
именно на первое движение вверх вниз после автохоум. Если сделаю подряд 10 раз, то подряд 10 раз повторится отказ Z. Но со второго раза все идет хорошо - хоть задвигайся)
19.07.18 в 07:27
печатает на Ultimaker 3 Extended
0
На всякий случай проверьте (поменяйте местами) концевик по оси Z, может он не срабатывает при первом смещении (попробуйте изменить толщину первого слоя на 0.4 например, если проблема уйдёт, то виноват концевик). А дальше ищите проблему в прошивке. Замените на другую.
19.07.18 в 08:01
0
Выяснилось(не было необходимости проверять) что все оси себя так ведут. Именно при смещении на +0.1 ось на -0.1 не реагирует. При следующих командах все впорядке.
попробуйте изменить толщину первого слоя на 0.4 например, если проблема уйдёт, то виноват концевик
Это даже все не при печати происходит. Перемещение оси 0.1 и 1 мм

Сейчас попробую залить стоковую прошивку
19.07.18 в 20:42
0
Может, дело в математике и округлении? Банально, гденить получатся "лишний" микрошаг, который вызывает сработку софтовых эндстопов.
Если сделать -0.2, +0.19?
19.07.18 в 21:46
0
Тут пожалуйста поподробней. Где что подкрутить?

P.S. На дисплее и в программе все отображается якобы работает исправно. +/- 0.1 или 1

Стоковый Marlin долго настраивать и опыта нет. Может быть у кого есть под Anet E10? Одну уже давали
Гуглить не пробовали? https://www.thingiverse.com/thing:2797792/files
Но ведет она(или не она) себя так

Для написания комментариев, пожалуйста, авторизуйтесь.