Пытаюсь разобраться с GRBL, не могу запустить движки

Crab
Идет загрузка
Загрузка
24.04.2019
216
10
Вопросы и ответы
Подскажите, люди добрые... купил шилд под Arduino Nano c драйверами 4988, и пару моторов NEMA17. Собрал все на коленке побаловаться, залил GRBL в ардуину (все норм), но могу даже запустить мотор. Не могу понять, то-ли подключаю неправильно, то-ли в GRBL что-то надо править.

Обмотки прозвонил, получается красный-синий, и зеленый-желтый. На драйвер вешал и так и этак - нифига.

Распиновка там 1В-1А-2А-2В, вроде получается надо цеплять красн-синий-желтый-зеленый (или как?). В этом случае при команде, например, X100 (двиг повесил на ось X) - вал двигателя блокируется на какое-то время, и на этом все.

Куда копать?
Ответы на вопросы

Ответы

24.04.2019 в 08:49
0

а они и н ебудут двигаться без парковки в home (он незнает начало координат вот и стоит)

24.04.2019 в 09:05
0

Ну в сторону home то должны двигаться.

24.04.2019 в 09:10
0

только при команде парковки а так не сдвиниться никуда

24.04.2019 в 09:16
0

Да, странно, а у меня едет, но только в плюс.

24.04.2019 в 09:21
0

Не нужна никакая команда парковки. Всё и без неё прекрасно двигается 
Вы GRBL настроили? 
ТУТ почитайте.
Ну и с полярностью обмоток поиграйте. 

24.04.2019 в 09:27
0

Мне бы для начала понять, правильно ли я вообще обмотки цепляю. Как обмотки на драйвере нумеруются? 1B и 1А - это одна обмотка? Или наоборот - 1А и 2А?

24.04.2019 в 09:49
0

1B и 1А - это одна обмотка

24.04.2019 в 09:51
0

Если прозвпнивается красный-синий, и зеленый-желтый то подключено все правильно. В настройках GRBL нужно шаги на мм настроить и ускорение. Ещё на драйверах vref. И тогда пробовать двигать оси.
Но.. Что за клеммы на последней фото вправа? Там не замыкает красный и желтый? 

24.04.2019 в 10:37
0

Насколько помню, порядок цветов должен быть одинаков на обоих концах шлейфа. Потом только перевернуть Молекс, если направление будет не то.

24.04.2019 в 15:12
0

у меня на такой плате (это по фотке сбоку сужу - сравнить можно у меня в профиле - статья про чпу-фрезер) был заводской косяк, проявлявшийся примерно также - двигатели не крутились, а дрыгались. оказалось, что в разводке местами попутаны DIR и STEP выводы драйверов. можно глянуть в прошивке, на каких выводах они висят, да прозвонить. если найдётся ошибка, поменять в прошивке (или, как сделал я, перерезать и перепаять дорожки). кстати, у меня же на этой плате ещё и был с завода запорот микростеппинг (перемычки деления шага ни на что не влияли), так что тоже может всплыть.

а с обмотками надо прозвранивать и пробовать. на разъёме драйвера два левых контакта - одна обмотка, два правых - вторая. если вызвонить обмотки, то комбинаций с полярностью всего несколько и на перебор всех вариантов уходит секунд 40 - куда быстрее, чем искать даташиты и что-то сопоставлять.

Для написания комментариев, пожалуйста, авторизуйтесь.

Читайте в блогах

3D печать и полиграфические услуги: как сэкономить на дорогостоящих и недолговечных деталях

Троллейбус

Оптические концевики

D-материалы как новые термины Формнекста

Фотополимерная печать, небольшая уловка.

Реестр печати с расчетом