Проблема с платой SKR 1.3

Подписаться на 3Dtoday
DrGrego
Идет загрузка
Загрузка
26 Июня 2019
397
52
печатает на Anet A6
Вопросы и Ответы
Помогите пожалуйста, купил недавно SKR по инструкции от Дмитрия Соркина установил прошивку, при подключении к repetier-host программа зависает а через некоторое время выдаёт ошибку подключения. При повторной попытке подключиться говорит что неправильно настроены параметры принтера. От чего это может быть и что делать в этой ситуации?
Ответы на вопрос

Ответы

26.06.19 в 15:01
печатает на RepRap
1
Если по его инструкции настраивали, значит и у него спросить "что за фигня" )
26.06.19 в 15:22
печатает на Anycubic i3 Mega
1
нормальную программу попробовать
у меня с октопринтом все щикарно работает и плата при этом постоянно как флешка видится компом
26.06.19 в 16:26
печатает на Ender 3
1
Вы наверное не заметили, что видео о том как залить Marlin на SKR 1.3, но до этого его еще и настроить не мешало бы.
26.06.19 в 18:23
печатает на Anet A6
0
Сначала пробовал настроить, результата ноль, потом попробовал поменять от стандартного конфига только плату и раскомментировать 2 serial порт
26.06.19 в 18:26
печатает на Ender 3
0
#define SERIAL_PORT 0

#define SERIAL_PORT_2 -1

Вот так должно быть
26.06.19 в 18:27
печатает на Anet A6
0
Так и сделал
26.06.19 в 18:31
печатает на Ender 3
1
#define DEFAULT_MINSEGMENTTIME 50000
#if ENABLED(SDSUPPORT)
#define BLOCK_BUFFER_SIZE 32
#else
#define BLOCK_BUFFER_SIZE 16
#endif
#define MAX_CMD_SIZE 96
#define BUFSIZE 32
#define TX_BUFFER_SIZE 32

Это делали?
26.06.19 в 18:36
печатает на Anet A6
0
Нет, спасибо за наводку. Сейчас попробую
26.06.19 в 18:58
печатает на Anet A6
0
Не помогло. Всё равно repetier пишет что устройство не поключено или выставлены неправильные параметры подключения
26.06.19 в 19:00
печатает на Ender 3
0
Посмотрите порт принтера в "Диспетчере устройств" и укажите их в Репитере
26.06.19 в 19:02
печатает на Anet A6
0
Уже проверял и делал. Искал и на зарубежных форумах но ответа не нашёл
26.06.19 в 19:04
печатает на Ender 3
0
Скорость еще как вариант
26.06.19 в 19:05
печатает на Anet A6
0
в прошивке 115200 в репетиере так же
26.06.19 в 19:14
печатает на Anet A6
0
поставил в настройках порта скорость 115200 сразу после перезагрузки платы подключается но если попробовать подключиться когда плата уже включена выдаёт ошибку а при отключении репетиер вылетает
26.06.19 в 19:18
печатает на Ender 3
0
Возможно кто то еще занимает порт, слайсер например
26.06.19 в 19:23
печатает на Anet A6
0
а это можно как-то проверить?
26.06.19 в 19:29
печатает на Ender 3
0
В принципе, можно, но это не так просто)))
26.06.19 в 19:26
печатает на Ender 3
0
Слайсер если запущен то, Cura например, то он точно подключится.
26.06.19 в 19:32
печатает на Anet A6
0
cura не запущена. только репетиер
26.06.19 в 19:39
печатает на Ender 3
0
Ну вообще то если первый раз подключается, а потом не может, то проблема не в плате, а в компе,скорее всего. Он у вас почему то не освобождает порт, ну или плата думает что он занят. Кстати попробуйте в диспетчере устройств назначить другой порт.
26.06.19 в 19:46
печатает на Anet A6
0
при переназначение проблема остаётся. ещё заметил что при отключении питания плата в репетиере остаётся подключеной, тогда как со стандартной анетовской платой такого нет и при отключении питания репетиер отключает плату
26.06.19 в 19:49
печатает на Ender 3
0
Перемычка на питания на плате к каком положении? Должна быть как на картинке если питается от внешнего питания
26.06.19 в 19:53
печатает на Anet A6
0
Стоит так как на картинке
26.06.19 в 20:00
печатает на Ender 3
0
Должна отключаться, может Репитер кривой, или встал криво
26.06.19 в 20:02
печатает на Anet A6
0
Даже если и кривой, то почему другая плата работает и подключается к нему нормально? Сейчас попробую переустановить но не уверен что это даст эффект
26.06.19 в 20:11
печатает на Ender 3
0
А диоды на плате гаснут при выключении питания?
26.06.19 в 20:17
печатает на Anet A6
0
гаснут, в компе порт пропадает
26.06.19 в 20:18
печатает на Ender 3
0
Попробуйте прошивку с моей платы, https://ru.files.fm/u/zu549fhz , у меня репитер норм подключается
26.06.19 в 20:27
печатает на Anet A6
0
установил. подключается так же только сразу после перезагрузки, но теперь перестал выводить информациюю с моей прошивкой при запуске показывалось что марлин 2.0 сейчас этого нет
26.06.19 в 20:29
печатает на Ender 3
0
Флешку поменяйте, прошивка у вас не правильно заливается. На экране он у вас должен Ender-3 написать)))
26.06.19 в 20:52
печатает на Anet A6
0
поменял флешку, эффекта 0 вообще ничего не происходит. прошивка даже не заливается
26.06.19 в 20:55
печатает на Ender 3
0
Прошивка должна заливаться, плата сама её подтягивает если видит на флешке файл Firmware.bin. Что прошивка залилась можно понять по переименованию файла, это плата сама делает
26.06.19 в 20:55
печатает на Anet A6
0
при этом со стоковой флешки прошивка заливается
26.06.19 в 20:56
печатает на Ender 3
0
Отформатируйте, ту с которой не заливается
26.06.19 в 20:59
печатает на Anet A6
0
уже во все форматы прогонял
26.06.19 в 21:00
печатает на Ender 3
0
FAT32 должна быть
26.06.19 в 21:02
печатает на Anet A6
0
его я попробовал самым первым
26.06.19 в 21:03
печатает на Ender 3
0
Вообще с моей прошивкой у вас принтер работать нормально скорее всего не будет, но к репитеру должен без проблем подключаться. Все танцы с бубнами уже попробовали, смею предположить что проблема в плате и пора попросить китайца о замене.
26.06.19 в 21:43
печатает на Anet A6
0
Спасибо за помощь, хоть ничего и не вышло. Открыл спор теперь остаётся только ждать, а пока буду пробовать дальше
26.06.19 в 21:45
печатает на Ender 3
0
Подождите, это похоже ещё у меня прошивка кривинькая)))
26.06.19 в 21:51
печатает на Anet A6
0
Хорошо, жду)
26.06.19 в 21:57
печатает на Ender 3
0
https://ru.files.fm/u/c54a7w78 вот нормальная
26.06.19 в 22:10
печатает на Anet A6
0
со стоковой залилась но с подключением проблемы остались(((
26.06.19 в 22:12
печатает на Anet A6
0
пробовал установить usb драйвера smootheiware но с ними не отображается вообще, а с usb дровами марлина отображается но не всегда. иногда не опознаёт
26.06.19 в 22:14
печатает на Ender 3
0
У меня винда сама дрова поставила, я даже не трогал ничего, попробуй удалить драйвера. как вариант.
26.06.19 в 22:32
печатает на Anet A6
0
комп вообще перестал видеть плату. надеюсь это временно
26.06.19 в 22:38
печатает на Ender 3
0
Нажмите поиск оборудования в диспетчере устройств он её найдет и усттановит драйвер мелкасофта
27.06.19 в 08:45
печатает на Kossel Kit
1
У меня с внешним питанием сразу после включения платы появляется порт в диспетчере устройств, отрывается флешка, но репитер пишет порт занят. Если нажать кнопку сброса на плате, то начинает подключаться.

В прошивке стоит скорость 250000.
Вечером попробую на других скоростях.

Плату только получил, еще толком не настраивал, пока печатает ужасно :)
27.06.19 в 09:58
печатает на Anet A6
0
В видео от Bigtreetech в прошивке ставили скорость 115200
27.06.19 в 10:52
печатает на Kossel Kit
0
Ну вот и проверю, поможет или нет.
Ну и плюс еще критично качество и длина USB кабеля.
При тестовом подключении коротким комплектным, все отлично. При подключении платы вставленной в принтер, короткого кабеля не хватает, подключал через переходник, длинным кабелем. Уже не подключается. пришлось принтер ближе к компу перетащить и внатяжечку получилось подключить кабелем 1.8м от сканера НР.
27.06.19 в 10:54
печатает на Anet A6
0
Я пробовал и коротким комплектным и длинным от Anet'a результат тот же
29.06.19 в 16:36
печатает на Anet A6
0
Нашёл в чём проблема. я дебил и сразу не додумался до этого. Я не мог подключить плату после запуска так как не были подключены термисторы и в итоге срабатывала термозащита. После подключения термисторов стола и экструдера проблема исчезла. Всем кто отвечал и предлагал варианты решений спасибо.

Для написания комментариев, пожалуйста, авторизуйтесь.