LCD2004 не работает в repetier firmware.

Роман73
Идет загрузка
Загрузка
20.08.2019
76
6
Вопросы и ответы
Добрый день. Имеется сборка Мега2560+ RAMPS1.4. Подключен LCD2004. На экране две полосы квадратов. Экран проверил скечем Hello World. Все ОК. Прошивка Repetier. Может кто знает, где можно выставить нужный экран в программе. Configuration.h, ui.h и uiconfig.h перелопатил, но так и не нашёл. Тыкните пальцем пожалуйста, а то с меня уже дым валит. К стати конструктором не работает. Шнурки целые, не перепутаны, контрастность выставлена нормально. Спасибо.
Ответы на вопросы

Ответы

20.08.2019 в 13:56
1

Загрузи в онлайн конфигуратор. И там поправь.
Должно заработать.

20.08.2019 в 14:07
0

В том то и дело, что не работает. Это первое, что я попробовал.

20.08.2019 в 16:03
0

все параметры дисплеев прописываются https://github.com/repetier/Repetier-Firmware/blob/master/src/ArduinoAVR/Repetier/uiconfig.h в этом файле

20.08.2019 в 16:08
0

отрегулировать контрастность

20.08.2019 в 16:11
1

Всем спасибо. Решено. Дисплей выставляется в configuration.h  FEATURE_CONTROLLER n, где n это номер дисплея из списка в Repetier.h.
А проблема была в не рабочем пине 29. Новая плата!!! Теперь надо переопределять на другой пин и ставить перемычку на RAMPS.

20.08.2019 в 17:16
1

Перепаял на 43 пин Rams и в ui.h поменял номер пина с 29 на 43. Все заработало.

Для написания комментариев, пожалуйста, авторизуйтесь.

Читайте в блогах

Модель ключа - трёхгранника

Самое бюджетное решение выключения принтера программной кнопкой (Автовыключение после печати)

PARAVAN и BigRep: Новый тип рычагов управления

Фигурка ко дню строителя.

Сглаживаем слои на модели! Как лучше подружить ABS с ацетоном: холодная, горячая баня или кисть?

Печатаем со сверхзвуковыми скоростями. 100мм/с, 200мм/с, 300 мм/с, .... 750 мм/с не предел !!!