Индуктивный датчик LJ12A3-8-Z/BX и плата MKS BASE V1.5

Подписаться на 3Dtoday
Fuego
Идет загрузка
Загрузка
7 Июня 2017
3169
10
печатает на RepRap
Вопросы и Ответы
Предыстория: Было куплено два обозначенных в заголовке датчика, и, когда пришло время их использовать, на каждом из них был распаян "делитель" по этой инструкции (буквально, т.е. между "сигнальным" и "минусом";), так как запитываться они будут от 12В. Один датчик подключался к плате Mastertronics (не Pro) — питание от колодок, что рядом со входным питанием + "сигнальный" на "S" Zmin; другой запитывался прямо от клемм БП а "сигнальный" так же на "S" Zmin платы RAMPS 1.4. На обеих платах все работало (при срабатывании загорался светодиод + по M119 выдавался "H"igh) и т.п.

Текущий момент: Плату Mastertronics заменил на MKS BASE V1.5 — всё настроил, кроме отработки Zmin, на котором висит датчик. Датчик запитал от одного из двух, предусмотренных для подключения чего-то дополнительного, разъемов 12V/24V (на изображении — правый нижний угол — "Fan Connections 12V-24V"). При срабатывании (подношу что-нибудь металлическое к концу датчика) светодиод загорается, а по M119 все равно "L"ow. Замерил напряжение на этих разъемах — 12В, а напряжение "сигнальный"–"минус" датчика — 3В. При срабатывании — 0В. Получается, порог срабатывания для платы больше чем мои 3В? А почему тогда на двух других платах это работало? Или эти разъемы питания на этой плате какие-то "хитрые"?
Ответы на вопрос

Ответы

08.06.17 в 02:50
печатает на Prusa
0
А без датчика что М119 пишет? Может вход платы сконфигурирован без подтягивающего резистора (pull-up) и что-то нужно в прошивке изменить? Иногда эти датчики нормально работают и от 5В, у меня LJ12A3-4-Z/BX (4мм) работает без проблем 4,7-5В.
08.06.17 в 16:47
печатает на RepRap
0
Без датчика M119 так же пишет zProbe: L (другого я и не ожидал — инверсия уже настроена).
Z_PROBE_PULLUP (прошивка Repetier) так же пробовал включать — никакого изменения в ситуации. При подключении ко всем тремя выводам Zmin (т.е. питание 5В) ситуация такая же — просто расстояние срабатывания (самого датчика) уменьшается а мне этого уже не хватает (расстояние над столом + зеркало 4мм + фольга).
Сам Zmin рабочий — проверял, временно подключив концевик Zmax.
Датчик рабочий (оба) — подключил на уже голую Mastertronics — напряжение "сигнальный"–"минус" датчика — 3В. Т.е. все тоже самое, только по M119/G31 реакция есть и она верная.
08.06.17 в 18:13
печатает на RepRap
0
Делитель напряжения построен с R1 = 20 кОм и R2 = 10 кОм, т.е. по расчетам должно быть на выходе 4В (при входном 12В). Почему получаю 3В — кто-то "съедает"? Я в этом не силен.
Единственное, что остается, это "перенастроить" делитель (R1 взять 15 кОм), чтобы на выходе получалось расчетные 4.8В (возможно, реальные будут 3.8В, если принять что "потеря" будет такой-же — в 1В).
09.06.17 в 13:05
печатает на RepRap
1
Итог: подключать для теста на 5В пины с делителем напряжения (1:3) и писать что не работает/происходит ухудшение срабатывания самим датчиком было большой глупостью, так как делитель делал свое дело и в итоге диапазон сигнала был 0 – 1,6В (а может еще меньше), что конечно очень мало для того чтобы плата посчитала это изменением уровня сигнала. И поэтому никак не реагировала. Но и мои 0 – 3В тоже малы для этой платы. Так что или делитель напряжения надо выполнять из расчета на выходе получать около 5В (наминалы резисторов R1 и R2 подбираются в зависимости от запитываемого напряжения) или просто подключать датчик напрямую (без делителя) ко всем трем пинам Zmin (или какой вам надо).

Сейчас подключил напрямую — все отлично срабатывает уже на большей высоте от стола (от фольги под зеркалом), так что я даже увеличил зону замеров.
10.11.17 в 09:28
печатает на TEVO Tarantula
0
То есть вы подключили без делителя 12в на плату? И что не сгорела:o?
10.11.17 в 10:24
печатает на RepRap
0
Напрямую не к 12В (т.е. не подпитывать от 12В) а ко всем трем выходам нужного концевика (+ - S — Zmin, например) — там же не 12В, а 5В (если плата нормальная и падения напряжения не происходит).
10.11.17 в 14:07
печатает на TEVO Tarantula
0
что-то я не совсем понял на MKS разъем z- +5 GND D18. Куда какие провода от датчика подключали?
10.11.17 в 14:30
печатает на RepRap
0
Согласно

сайта инструкции): Синий/Blue = минус/GND, Коричневый/Brown = +5V, Чёрный/Black = S (D18).
10.11.17 в 15:45
печатает на TEVO Tarantula
0
спасибо попробую, а на 5в чуствительность не ухудшиться датчик написано от 6 в до 36 в. а с платы 5в береться.
10.11.17 в 18:29
печатает на RepRap
0
Да, написано так, но у меня проблем не было с чувствительностью — светодиод горит ярко, срабатывание на грани максимума (эта модель датчика рассчитана на 8мм — у меня зеркало 4мм и несколько слоев фольги [не в счет] под ним).

Для написания комментариев, пожалуйста, авторизуйтесь.