CP2102 NodeMcu V3 Lua

comrat
Идет загрузка
Загрузка
28.04.2019
395
62
Вопросы и ответы
Статья относится к принтерам:
Prusa
Добрый день.приобрел данный модуль, прошил, подсоединил к Rams 1.4. В домашней сети модуль вижу.
но принтер не отвечает ни через одну программу...может кто сталкивался?..спасибо.
Ответы на вопросы

Ответы

28.04.2019 в 17:40
0

не отвечает ни через одну программу
Ммм... А какие, собственно, вы пробовали? 
И какие прошивки в esp и меге? Веб-интерфейс открывается? Модуль пингуется?

28.04.2019 в 17:46
0

pronterfase....peretier-host

28.04.2019 в 17:59
0

Marlin в меге....в esp esp3d 0.6.2.....да  интерфейс отрывается скриншот сделан с ноутбука

28.04.2019 в 18:09
0

Baud Rate совпадает? В pronterfase, peretier-host порт указан верно?

28.04.2019 в 18:15
0

да все совпадает....порт 8888

28.04.2019 в 18:17
0

Странно... Телнет к этому порту коннектится?
Ну и провода точно правильно подключены? Согласование уровней какое-то есть?

28.04.2019 в 18:22
0

незнаю даже...непробовал...

28.04.2019 в 18:25
0
28.04.2019 в 18:34
0

Может диод стоит 'вверх ногами'? Да и вообще он тут не очень-то и нужен. Попробуйте без него.
И, кстати, а из веб интерфейса принтер не рулится случайно? Может дело и не в железе вовсе...

29.04.2019 в 01:51
0

из веб интервейса принтер тоже не рулится...

28.04.2019 в 18:25
0

вот так подключил

28.04.2019 в 18:37
0

и без него пробовал...тишина..

28.04.2019 в 18:47
0

Можно попробовать уменьшить R2 раза эдак в два (можно паралельно поставить такой же) . Но есть риск! 
По-хорошему бы надо посмотреть что творится после делителя. Осцилографа нет случайно?
Да, кстати. USB кабель от меги должен быть обязательно отключен.

28.04.2019 в 18:57
0

кабель отключен...ослик есть..

28.04.2019 в 19:02
0

Это хорошо! Гляньте что там делается после делителя. При передаче команд на принтер должны быть импульсы с амплитудой около 3-х вольт.

28.04.2019 в 19:04
0

хорошо посмотрю..а порт не может быть закрыт?

28.04.2019 в 19:09
0

Вряд ли. Но можете проверить - telnet 192.168.0.130 8888

28.04.2019 в 19:07
0

Кстати, а почему esp3d 0.6.2? Я в свое время ставил 1.0, никаких проблем не наблюдалось. Правда сама концепция не прижилась, но по другим причинам.  Я не к тому что 0.6.2 чем-то плоха, просто интересно.

28.04.2019 в 19:10
0

да первое что попалось...

28.04.2019 в 19:14
0

 Ведь попасться могло такое... Возьмите официальную версию, может вам просто попалась забагованная.

28.04.2019 в 19:13
0

 telnet 192.168.0.130 8888.....и что я должен с этим сделать?

28.04.2019 в 19:19
0

Ввести в командную строку. Если сразу не выйдет то соединение установлено, значит  порт открыт.

28.04.2019 в 19:21
0

открыт..

28.04.2019 в 19:24
0

я пробовал эту версию...ардуинка ругается...не компелирует

28.04.2019 в 19:28
0
29.04.2019 в 08:31
0

Тут была похожая проблема.

28.04.2019 в 19:35
1

Если в  меге установлен USB-to-TTL на базе ATmega16U2, то скорее всего данным способом подключения не получится осуществить затеянное, по крайней мере у меня не вышло, т.к. ATmega16U2 даже без подключенного кабеля USB блокирует serial порт меги.

29.04.2019 в 02:34
0
29.04.2019 в 02:36
0

первая с тх модуля...вторая с rx

29.04.2019 в 08:21
0

Что-то тут не так. И на тх и на rx модуля присутствуют 5В.
Ну никак не может быть после делителя 5в, на то он и делитель. И на TX не может быть, если стоит диод. Максимум 3.3.

29.04.2019 в 13:28
0

в чем может быть проблема?

29.04.2019 в 14:10
0

Да ктож его знает. Может проблема с коммутациями. Для начала можно оставить только делитель подключенный к меге (рампсу). На его средней точке должно быть около 3-х вольт. Если это не так то в вашем конкретном случае закон Ома не работает.

29.04.2019 в 14:32
0

3,24 В...

29.04.2019 в 14:42
0

Отлично, фундаментальные законы еще действуют. А если теперь к этой точке подключить RX вемоса, ну и землю с питанием, и померить напряжение там же.

29.04.2019 в 14:43
0

промерил еще раз 3,24 на обеих выходах...

29.04.2019 в 14:45
0

Вы тестером мерили? А осцилограф что показывает?

29.04.2019 в 14:49
0

тестером...ослик 3,2 показывает...первый раз неверно промерил ..

29.04.2019 в 14:54
0

Ну так может уже заработало все. Подключайте TX и попробуйте.

29.04.2019 в 15:04
0

увы...все как прежде...

29.04.2019 в 15:09
0

А на осцилографе в момент передачи команд на принтер что-нибудь происходит?

29.04.2019 в 15:14
0

да нет...ничего...пробую прошивать esp3d обновил библиотеку прошивка прошла ...при нажатии на sketch data upload вылазит следующее

29.04.2019 в 15:19
0

все решил..

29.04.2019 в 15:05
0

в прошивке ничего менять не нужно?

29.04.2019 в 15:12
0

Да нет, для прошивки это выглядит как команды с USB.
Возможно у вас тот случай о котором говорил Roman-RV. Если отключить esp и подключить USB кабель, мега в операционной системе как видна?

29.04.2019 в 15:48
0

CH340

29.04.2019 в 15:53
0

Вот именно с ним у меня прекрасно работало. Удалось скомпилировать прошивку?

29.04.2019 в 15:56
0

да все встало...

29.04.2019 в 15:56
0

соединения с принтером нет..

29.04.2019 в 15:58
0

может быть почистить esp и загрузить на чистую?..как только это сделать я незнаю...

29.04.2019 в 16:13
0

Да нет, не нужно. Сама прошивка-то отлично работает. Может TX/RX не туда подключены? Тем более вы говорите что на осцилографе не видно пачки импульсов.

29.04.2019 в 16:16
0

подключал вот так

29.04.2019 в 16:29
0

Мистика какая-то, ну абсолютно все верно! Остается только прозвонить цепи Rx/Tx на меге и рампсе на предмет обрывов/замыканий. Особенно на рампсе. Мне встречались такие китайские поделки что без слез смотреть нельзя было.

29.04.2019 в 16:42
0

вот когда прошивал последней прошивкой модуль сразу появился в домашней сети...хотя должен же был сначало определится как точка доступа...я бы очистил его для уверенности..как только?

29.04.2019 в 16:56
0

Он сохраняет настройки в EEPROM (точнее в его эмуляции), который не затирается при перепрошивке. Но можете его отдельно почистить. Хотя я не вижу в этом смысла.

29.04.2019 в 17:01
0

вот тут я слаб...что мне нужно сделать для этого?

29.04.2019 в 17:12
0

Это обычный скетч для Arduino IDE. Вот он в виде файла. 
Просто прошить им  модуль, можно перегрузить для надежности, после чего загрузить прошивку ESP3D обратно.

29.04.2019 в 17:49
0

Вы правы...ничего не поменялось...единственное указывал порт ip адрес 192.168.0.130   а присвоился почемуто 192.168.0.194 хотя и в настройках 130 стоит..

29.04.2019 в 18:15
0

я так понимаю rx tx от рамса идут на соответствующие входа меги 2560....а вот где они?...может и правда дело в контакте..

30.04.2019 в 03:45
0

похоже что у меня тоже самое...[url]https://3dtoday.ru/blogs/eta4ever/a-sudden-rake-from-sky-engineers/......БОЛЬШОЕ спасибо всем кто помогал , особенно Pey'j. Все заработало...ответ загадки тут..https://www.thingiverse.com/thing:2542277

29.04.2019 в 02:57
0

[IMG]https://cloud.mail.ru/stock/TdDPRjPrKvaQmo4P2PhGDxzm[/IMG]

29.04.2019 в 02:59
0

это после делителя

Для написания комментариев, пожалуйста, авторизуйтесь.

Читайте в блогах

Символ наступающего года.

Подставка под миниатюру Джона Уика.

Мелкая деталька - моделирование и печать (триллер с элементами детектива) :)

Sirius Hardlight - Принтер который вы искали

Печатаем гибкую, эластичную, мягкую деталь полимерником

КОМПАС-3D v18 Home. Основы 3D-проектирования. Часть 16.3. Создание игрушечного паровоза. Крыша и тележка паровоза