Шаговые двигатели пищат,но не крутятся

Подписаться на 3Dtoday
rain1986
Идет загрузка
Загрузка
14 Января 2018
1639
31
печатает на RepRap
Вопросы и Ответы
Всем привет.Подскажите в чем может быть проблема. Принтер h-bot. Мозги ruramps. Драйверы 8825.vref-0.7.При попытке подвигать ось х на шаг 1раздается писк,а двигатели не двигаются. При шаге 0.1 с шумом,но вращаются, а при команде home раздается писк. Может кто встречался с такой историей??Целый день пропрыгал вокруг принтера,а толка 0((((
Ответы на вопрос

Ответы

14.01.18 в 16:55
печатает на ZAV-MAX-PRO
0
Концевики на месте и работают?
14.01.18 в 17:04
печатает на RepRap
0
Концевики на месте;работают
14.01.18 в 17:32
печатает на Ultimaker Original
1
прозвоните пары двигателя мультиметром. Скорее всего неправильно подключили
14.01.18 в 17:41
печатает на RepRap
0
Прозванивал.Подключено правильно
14.01.18 в 17:45
печатает на Anycubic Kossel linear plus
0
Есть вероятность что одна обмотка подключена в прямом направлении, а одна обратно. Хотя тогда должны трещать
14.01.18 в 18:00
печатает на RepRap
0
Вот так подключены провода.Шаговые двигатели 17hs4401, прозваниваются красный/синий, зеленый/черный.
14.01.18 в 18:07
печатает на Anycubic Kossel linear plus
0
красный/синий поменяйте местами
14.01.18 в 18:51
печатает на RepRap
0
Не помогло
14.01.18 в 18:58
печатает на Anycubic Kossel linear plus
0
И ни чего не изменилось?
14.01.18 в 19:12
печатает на RepRap
0
Нет.Моторы все так же пищат,но не двигаются((
14.01.18 в 19:16
печатает на Anycubic Kossel linear plus
0
А перемычки там на плате ставить ни чего не надо под эти драйвера и под ваши двигатели?
14.01.18 в 19:23
печатает на RepRap
0
Перемычки тоже стоят верно
14.01.18 в 19:26
печатает на Anycubic Kossel linear plus
0
тогда даже не представлю.
14.01.18 в 21:07
печатает на RepRap
0
А оптический endstop ставится как нормально замкнутый?И в состоянии покоя светодиод гореть должен?
15.01.18 в 04:53
печатает на Ultimaker 3 Extended
0
Если речь про дешевые китайские, то да, они нормально замкнутые. Светодиод горит. И гаснет при размыкании светового потока.
В прошивке необходимо правильно прописать в нужных местах.
#define [ось]_MIN_ENDSTOP_INVERTING false
14.01.18 в 18:09
печатает на RepRap
0
748d85d62741af04755230c4e4ee4163.jpg

Сейчас вот так
Можно же и в прошивке поменять полярность?
14.01.18 в 18:30
печатает на Delta-X
1
В прошивке можно направление поменять, а полярность только физически
14.01.18 в 19:20
печатает на Ultimaker Original
1
У вас схема подключения a2a1b1b2. А поключаете как на ramps 1.4 2b2a1a1b
14.01.18 в 19:39
печатает на RepRap
0
7b52ded9a5ee181f305fc0fae9753426.jpg

Так?
14.01.18 в 20:46
печатает на Ultimaker Original
0
Синий черный красный зелёный должно быть
14.01.18 в 22:26
печатает на RepRap
0
Один движок заработал,но почему-то только один((
28.01.18 в 20:36
печатает на RepRap
0
Вообще-то странный вариант, если звонятся красный-синий/зеленый-черный
14.01.18 в 20:03
печатает на RepRap
0
А если поправить (уменьшить) ускорения/количество шагов на 1мм? Для эксперимента, для начала.
И можно еще чуток опорное снизить.
14.01.18 в 20:27
печатает на RepRap
0
Т.е выставить не 1/32, а 1/16?
14.01.18 в 20:35
печатает на RepRap
0
Ага.
Практика подсказывает, что шаговики пищат, когда управляющая частота (сигнал степ) выше, чем частота вращения шаговика.
14.01.18 в 20:42
печатает на RepRap
0
Но драйвера вроде бы под шаг 1/32
В прошивке(репитер) убрал значение задержки.Один движок портала начал крутиться
14.01.18 в 21:04
печатает на RepRap
0
Ускорения, джерки, скорость перемещения - копать в ту сторону надо.
28.01.18 в 23:18
печатает на Ultimaker Original
0
До сих пор чтоли не разобрались? Можно было бы все варианты перебрать :)
28.01.18 в 23:23
печатает на RepRap
0
Нет,еще не разобрался. Я уже какие знал,перебрал...
29.01.18 в 23:22
печатает на Ultimaker Original
0
Возможно автор ruramps сможет вам помочь.
http://3dtoday.ru/blogs/svs0724/
29.01.18 в 23:27
печатает на RepRap
0
Обращался.Пока без результатов...

Для написания комментариев, пожалуйста, авторизуйтесь.