Принтер не реагирует на Repetier Host

Подписаться на 3Dtoday
DIG_tlt
Идет загрузка
Загрузка
7 Апреля 2016
6646
12
печатает на Prusa i3 Steel - DIY
Вопросы и Ответы
Помогите чайнику.
Принтнр Prusa i3 на RAMPS 1.4
Установил Repetier Host 1.6.1.
Выставил в настройках порт, скорость, при нажатии на вилку - якобы с принтером соединяется, вилка зеленеет, ошибок нет.
Но ни на какие команды Repetier Host принтер не реагирует.
Ответы на вопрос

Ответы

7 Апр 07:11
печатает на RepRap
0
Смотрите как подключены концевики. Может ошиблись. Он считает что в доме стоит. Чтобы консоле пишет?
M119 этотконцевики
M114 это координаты.
7 Апр 07:25
печатает на Prusa i3 Steel - DIY
0
Вот кусок лога после M114:

08:16:45.957 : N21 M114*20
08:16:48.688 : N22 M105*23
08:16:51.751 : N23 M105*22
08:16:54.806 : N24 M105*17
08:16:57.863 : N25 M105*16
08:17:00.917 : N26 M105*19
08:17:03.974 : N27 M105*18
08:17:03.980 : echo:Unknown command: ""
08:17:03.980 : ok
08:17:07.035 : N28 M105*29
08:17:10.090 : N29 M105*28
08:17:10.097 : echo:Unknown command: ""
08:17:10.097 : ok
08:17:13.153 : N30 M105*20

Вот после M119:

08:19:13.836 : N46 M119*24
08:19:13.859 : echo:Unknown command: "[?"
08:19:13.863 : ok
08:19:15.469 : N47 M105*20
08:19:18.526 : N48 M105*27
08:19:21.588 : N49 M105*26
08:19:24.643 : N50 M105*18

Я думаю может проблемы со шнуром USB, хотя прошивается через него без проблем.
7 Апр 08:11
печатает на RepRap
0
Мусор какой то. Вывода комманд нет вообще.
7 Апр 08:39
печатает на Prusa i3 Steel - DIY
0
Ну и куда копать?
7 Апр 08:53
печатает на RepRap
0
Судя по ответам принтера, он вместо команд получает белиберду.
Вероятно скорость соединения неправильно выставлена. Должна совпадать в прошивке и настройках.
Принтер сбрасывается при подключении к нему (заставка должна проскочить)? В противном случае serial connection будет не синхронизировано, он будет получать полный бред.
7 Апр 09:00
печатает на Prusa i3 Steel - DIY
0
Да вроде всё везде одинаково...
Скачал pronterface - заработало сразу. Всё ездит куда надо и как надо, я прям в счастье :)
Еще попробовал MatterControl- тоже всё работает с полпинка.
7 Апр 09:34
печатает на RepRap
0
Переставьте repetier.
7 Апр 20:52
печатает на Prusa i3 Steel - DIY
0
Переустановил repetier- всё заработало. В чем была причина - непонятно.
7 Апр 21:49
печатает на RepRap
0
Причина в Микрософте
10 Апр 22:34
печатает на Prusa i3 Hephestos
0
У меня было похожее, вылетел усб интерфейс на ардуино, но иногда вылазило, что устройство усб работает некорректно
29 Сен 15:06
печатает на Felix 2.0
0
Проблема: Repetier Host на любые команды пользователя не отвечал. Просто говорил: "Ожидание команды N", где N - количество команд, которые мы дали принтеру (проще говоря, сколько мы всего натыкали). Драйвера оказались в порядке, если не ошибаюсь, скачивал дрова отсюда: http://devid.info/ru/202993
Решилась проблема так: перебирал разные скорости в бодах и пробовал тыкнуть на "Домик с иксом (X)" или любую другую кнопку. В итоге у меня заработал принтер на скорости 57600 бод (у вас может быть и другая скорость).
Ещё возможное решение проблемы - установка аналогичного ПО, например pronterface.

У меня стоит ОС: Windows 7 x64 Home Basic.
Версия Repetier Host: 1.5.6. (на 1.6.2 не пробовал, ибо в поисках решения проблемы поставил 1.5.6)
14 Апр 06:34
печатает на Prusa i3
0
У меня было то же самое. Принтер подключался, но не на что не реагировал. Заменил кабель на штатный от Arduino, уменьшил скорость передачи - ничего не помогало. Поставил PRONTERFACE и все заработало на максимальной скорости, а в REPETIRE по-прежнему никак. Потом здесь прочитал про переустановку REPETIERa, переставил и все заработало на максимальной скорости - вот оно счастье!

Система Win-7х64 prof

Для написания комментариев, пожалуйста, авторизуйтесь.