При увеличении потребления тока РАМПСом АТХ уходит в защиту

Подписаться на 3Dtoday
Han
Идет загрузка
Загрузка
11 Августа 2018
289
18
печатает на RepRap
Вопросы и Ответы
Приветствую народ.

Буквально только что случилась с принтером некоторое дерьмо...
Решил я в кой-то веки заменить штатные клеммы питания на православную пайку напрямую. Всё прошло штатно, после чего понадобилось свапнуть шаговики осей (CoreXY) местами на плате. И когда отключал первый разъём, умудрился забыть выключить двигатель (он именно что был под напряжением и держал позицию). В итоге при отключении он немного искранул... Вроде потом всё подключил и проверил, проблем никаких.
Однако при запуске печати оказалось, что при наращивании нагрузки на РАМПСе АТХ уходит в защиту. Голову прогревает нормально (стол на отдельном БП), осями двигает нормально. Но как только двигает осями при нагретой голове, то сразу вылетает. Если после попытаться включить, то отваливается уже только от нагрева (в районе 205 градусов), либо раньше, если врубить двигатели. До этого система год работала без нареканий, иногда нон-стопом по неделе-две.

Собственно вопрос: что это за дичь такая? Частично сдох РАМПС, или что-то померло в БП? И имеет ли смысл пытаться повесить голову на второй блок, оставив на АТХ только движки и логику? Сам АТХ на 400W.

Заранее благодарю за советы.
Ответы на вопрос

Ответы

11.08.18 в 06:39
печатает на RepRap
0
UPD: Только что получилось запустить печать, но блок отвалился на первых секундах. С дежуркой кстати во время вылетов ничего не происходит. Как работала, так и работает...
11.08.18 в 08:19
печатает на TEVO Black Widow
0
А что за блок питания? Очень похоже по поведению на нестабильную работу БП.
11.08.18 в 12:23
печатает на RepRap
0
АТХ - этт блок питания от компьютера. Хрош тем, что имеет 3 разных напряжения, позволяет собой управлять и обвешан защитами чуть менее чем полностью.
11.08.18 в 16:02
печатает на TEVO Black Widow
0
Это понятно из текста. Что за производитель, какая мощность и сколько блок в работе (месяцы, годы)?
11.08.18 в 10:47
печатает на Delta-X
0
Могли подгореть и моторы и драйвера. Все операции вставить/вынуть производить с отключенным питанием!

1. выключите питание и отсоедините все моторы, включите питание и запустите печать, если продолжит уходить в защиту - продолжаем с пункта 4, если перестал с пункта 2.
2. выключите питание и подключите один мотор (кроме найденного нерабочего), включите и запустите печать
3. повторяйте пункт 2, пока не подключите все моторы.
4. выключите питание и отсоедините один драйвер, снова включите и запустите печать
5. повторяйте п.4 пока не перестанет уходить в защиту
6. выключите питание и вставьте один драйвер (кроме найденного нерабочего), включите и запустите печать
7. повторяйте пункт 6, пока не вставите все драйвера.
8. замените обнаруженные неисправные моторы и/или драйвера
9. если отключили все драйвера и все моторы а БП продолжает уходить в защиту - отключите всю нагрузку (вентиляторы, нагреватели, термисторы), если и без нагрузки уходит - плату управления на ремонт или замену.
з.ы.
нужно быть уверенным, что БП рабочий
11.08.18 в 12:33
печатает на RepRap
0
А если нет какого-то крнкретного неисправного драйвера или двигателя? Например если без нагрева ооловы нормально печатает? (сейчас пока доступа к принтеру нет, но предполагаю такой вариант)
11.08.18 в 17:12
печатает на Delta-X
0
Может мосфет подсел, не знаю... вероятнее всё же БП перестал вытягивать нагрузку
11.08.18 в 11:47
0
Включить, включить моторы на удержание, 5 минут, пощупать не греется ли сильнее других тот драйвер, на котором искру добывали. Если да - менять этот драйвер.
11.08.18 в 14:25
печатает на Prusa i3
0
Может, это все следствие "пайки напрямую"? Блок тянул все это на пределе, а тут хороший контакт возник, пиковые токи подросли, вот он в защиту и уходит.
Из опыта борьбы с АТХ блоками: попробуй его подгрузить чем нибудь по шине +5в. Например автомобильной лампочкой 12в 20вт (от поворотника) или сам придумай чем. Если все заработает- это она, магия АТХ :)

P.S. Несколько раз по неосторожности включал/выключал ШД под напряжением, с искрами. Ни разу ничего не выгорело, ТТТ.
11.08.18 в 16:26
печатает на RepRap
0
На 5в у меня вся логика висит. Или этого недостаточно? Лампочки под рукой нет к сожалению( Не подскажите, насколько примерно надо грузить линию 5в для стабильной работы? Слышал, что кто-то плату от жёсткого диска в качестве нагрузки втыкал...
11.08.18 в 16:32
печатает на Prusa i3
0
Я предпочел переделать свой БП, а вот знакомый долго печатал с тлеющей лампочкой, подключенной на 5В. Плата от винта - такая же фигня, как и "вся электроника". Хотя б ватт на 5 подгрузить, а лучше на 10. А это ток 1-2А должен быть.
Для начала может и правда открой блок питания и глянь, вдруг и правда там конденсаторы повздувались, потому и не тянет.
11.08.18 в 16:34
печатает на RepRap
0
Уже залез и посмотрел. Если и вздулись, то настолько слабо, что этого не заметно... Логика у меня на дежурке висит, так что 5в считай вообще пустые. Не поделитесь подробностями переделки?
11.08.18 в 16:49
печатает на Prusa i3
0
Два года назад дело было, подробностей не помню. Помню что контроль 5в вешали на 12в через делитель и ещё поднимали напругу, пока в защиту по превышению не начал уходить. Блок попался сильно умный, все напруги по максимуму и минимуму контролировал, а стабилизировался по 5в. Ковырялся сослуживец - электронщик со стажем, я только идеи генерировал :)
Но где то даже тут на тудэе была заметка, как правильно готовить АТХ для принтера.
11.08.18 в 17:04
печатает на Prusa i3
1
http://3dtoday.ru/blogs/fisher74/psu-atx-for-printer/ вот человек ковырялся и описывал
11.08.18 в 14:32
печатает на Prusa i3
0
Скорее всего проблема в Блоке питания. Открываем, проверяем на предмет вздувшихся конденсаторов, заменяем неисправные.
11.08.18 в 14:49
печатает на Anet A8
0
Голову прогревает нормально (стол на отдельном БП)
Електроника потребляет не более 2А, а подогрев сопла - 3А. Если 400Вт БП не в состоянии вьідавать 60Вт по 12в - хана ему.
11.08.18 в 19:47
печатает на Mendel Prusa
0
Термопредохранители проверяли на рампсе? Должны быть холодные. Если маленький горяченный, то дело не в блоке питания, а в термопредохранителях
11.08.18 в 20:27
печатает на RepRap
1
Вопрос решён. Всё оказалось достаточно тривиально: вздулась пара кондёров на блоке, просто они были запрятаны так, что я их сначала не заметил. Распаял новый блок, работает штатно. Благодарю всех за советы)

Для написания комментариев, пожалуйста, авторизуйтесь.