Реклама

mks sbase 1.3 HOTEND

Подписаться на 3Dtoday
oleg.andreychenko
Идет загрузка
Загрузка
17 Марта 2018
348
31
Вопросы и Ответы
Добрый день всем!

Delta, MKS Sbase 1.3, еае3.2, E3DV6, 12 V, стол - 220 V через fostek... все более-менее стандартно.

Нарвался на неожиданную проблему с нагревом три дня назад - решения найти не могу...

hotend стал очень медленно греться и не догреваться даже до 180 градусов...
Нагреватель менял
Термистор менял
Подключал голову к всем трем портам (E0, E1 и Bed)
Блок питания тоже менял :-)

Такое ощущение, что просто не хватает мощности на нагрев...
Если вытащить нагреватель из блока, смотать с термистором - греется как положено... в блоке - никак...

Какие будут идеи? Я уже всю голову сломал...
Ответы на вопрос

Ответы

18.03.18 в 03:07
печатает на Prusa i3
0
варианты
1. блок питания 12 вольт, термистр на 24 вольта?
2. в прошывке отрегулировать power 0-255, 255 максимум мощности
3. обмотать блочок каптоном, плохой контакт нагревательного елемента и блочка.
4. плохое прилегание датчика темератруы в блочке
5 излом проводов нагревательного елемента
6. в блоке питаня чатично вышел из строя ключь.
выбирайте что по душе.
18.03.18 в 12:08
0
1 1принтер до этого момента проработал около 3-х недель... таких проблем не было... блок питания меням... термистор менял, нагреватель менял...
2 где именно? не нашел...
3. нагреватель менял - результат одинаковый...
4. термистор менял... эффект - тот-же
5. нагревательный элемент менял...
6. блок питания менял...

как-то так...
18.03.18 в 06:51
печатает на Anycubic Kossel linear plus
0
Не верный пид. Тоже вариант развития событий.
18.03.18 в 12:09
0
но 2 недели с ними было все нормально...
даже закомментировал - тот-же результат
18.03.18 в 13:15
печатает на Kossel Kit
0
Если есть тестер ткните при разогреве хотэнда в его разъём на плате, на нём должно быть практически напряжение питания, если меньше оного то проблема в настройках либо самой плате, если напряжение норма то идём по проводам до самого нагревателя и всё проверяем.
18.03.18 в 13:52
печатает на Micromake D1
0
Термопаста есть? Намажьте нагреватель и термистор.
Нет термопасты? Подмотайте на нагреватель фольги от шоколадки, чтобы плотно прилегал к кубику.
Наверное перебирали экструдер? :)
18.03.18 в 16:31
0
если просто вытащить обогреватель из алюминиевого блока, примотать к нему термистор - греется быстро и до нормальной температуры...Но сил нагреться в блоке - не хватает... не могу понять причину.
18.03.18 в 18:52
0
Ну не бывает чудес! Мерием напряжение на нагревателе у головы и у платы. Что ушло должно прийти. Смотрим конфиг, не шимим ли мы нагреватель! Мерием сопротивление этого нагревателя, по закону ома считаем его мощность при данном питании. Должно выйти в районе 40 ва тт. Да ток потребления тоже можно померить. Электроника это наука о контактах! Недожал, обгорел, смотрим и чистим. Может тупо не пропай на плате. Чудесные китайские магнитящиеся провода?
Что там в слайсере, может он чудит. Установить температуру непосредственно из меню принтера.
18.03.18 в 22:54
0
чудес н бывает.... правда...
купил только что третий обогреватель и термистор - результат тот-же...
взял прошивку и конфиг просто с гитхаба с базовыми настройками - результат туда-же...

разобрал второй свой принтер, подключил нагревательный блок с термистором к нему - греется как положено! бістро и доржит температуру.
18.03.18 в 23:04
0
Ну тогда перенести на другой пин. Может этот полусдох.
18.03.18 в 23:43
0
пробовал на все три... и на второй єкструдер и на стол... результат - туда-же!
19.03.18 в 09:03
0
Если работает на другом принтере, а на этом со всеми танцами ни в какую, смотри блок питания тогда. Напряжение замерялось со всеми нагрузками? Может там 10в. А это уже очень критично для нагрева. Все будет работать, но греться еле еле. Если он регулируемый можно поднять напряжение на пару вольт.
Ну и еще раз, что там приходит на этот нагреватель? Замер непосредственно у головы. Может провод перетерся.
19.03.18 в 10:10
0
:-) на блоке питания стоит вольтметр... все гуд! Да и блок питания я тоже менял...

Вся проблема в том, что все три канала ведут себя одинаково... и оба хотэнда, и нагрев стола...

еще раз по порядку:
недели три, пока делал тонкую настройку - все работало нормально... копаться начал из-за подвисания sbase - об этом есть пара записей... и некоторое время назад, при очередном тесте нотэнд просто не смог разогреться до положенных 230 градусов... отсюда все и началось - смена блока обогревателя, смена канала, смена блока питания, обновление прошивки (как с мкс, так и со смузи даже с типовым стандартным конфигом)...

19.03.18 в 10:53
0
Ну sbase так врятли чудить будет. Чтобы по всем каналам плюс стол явно питание. Не доходит до потребителей. Что просится, это плохой контакт на самой плате. Ведь приходит все на нее, а раздает уже она всем. Смотри что там с контактами. Ну и еще раз, не важно что там показывает вольтметр на блоке питания, мерь непосредственно на голове и столе. Сразу станет намного легче ориентироваться. 12в питание? Если да то на 12в гуляют хорошие токи на все эти потребители, там провода потолще нужны и контакты частенько выгорают. Перебери эти разъемы. На 24 в проще, токи меньше в 2 раза.
19.03.18 в 11:04
0
Я уже отключил все. оставил только голоку...
Контакты - чистые. питающий кабель от блока питания - 10см, полтора квадрата многожильная медь...

Движки все крутились отлично... проблем не было. только нагрев...
Кто-нидь схемотехнику видел? Мосфеты между собой как-нибудь связаны?
19.03.18 в 11:13
0
Да там все просто. Это же ключи по сути, подали им на затвор 5в, они открылись. Они все сидят на этом питании, коммутируют каждый свою нагрузку. Если он накроется, то либо вечно нет напряжения, либо вечно открыт. Не лезь к ним, не в них дело.
Провод 1.5 квадрата это очень мало. Раза в 2 толще надо минимум. Токи гуляют под 30А, проводку дома на такие токи 4 квадрата делают. Не смотри что 12в.
Ну и еще раз, измерь непосредственно на столе и голове. Вот чую что просадка дикая в питании.
Потери на тонких проводах и хреновых контактах.
Ну поработал пару недель, подрыгал головой и пообломал жилы в своем проводе. Вот и хреновый контакт.

Еще, радиатор мосфетов холодный?
19.03.18 в 12:14
0
Ну, учитывая, что стол у меня 220 вольт - 30 ампер у меня не бывает... только пиковые, а они таких проблем не дают...
второй принтер работает с таким-же блоком питания уже месяцев семь - проблем нет совсем...

с контактами - все отлично - чистая красивая медь - дежн потемнеть не успела еще... да и блок питания менял...

но для проверки попробую сегодня еще раз блок питания поменять... на тот, который на corexy стоит... там тоже грелка 220 вольт, движков, больше
19.03.18 в 14:17
0
Я может быть покажусь занудой, но блин, сколько трепа ни о чем. Где замеры напряжения непосредственно у головы? Гадать можно долго, но нужны и цифры. Ушло столько, пришло столько.

И есть ли нагрев радиатора мосфетов? Может правда плата подсдохла, не выдает нужный уровень напряжения для открытия мосфетов, они в линейном режиме работают. Тогда нагрев будет заметный у них.

Грелка 220 это норм, бп гораздо спокойней жить.
У самого sbase с убитым одним каналом нагревателя, но тут сам виноват был, пока настроил этот обдув 12 в при 28 питающем и чтоб шимилось это дело.
А так у sbase был всего 1 глюк, зависала зараза. Не нравилась ей новая карта от кингстона, зависала с ней всегда, могла и через минуту, могла и через 3 часа. С другими картами никаких проблем.
19.03.18 в 14:27
0
это с флехой? или с сд?
я, собственно, чего ковырять стал принтер - та-же беда с зависанием... бывает примерно на одном и том-же месте... а бывает не висла сутки печати к ряду... пытался 12864 цеплять - висла намертво не доведя сопло до стола...

сегодня ШИМ на нотэнде попробую поменять на 240... может в пылу борьбы за зависание поменял...
19.03.18 в 15:19
0
Сд, экран обычный 12864. Карту можно вставлять только в саму плату sbase. В экран 12864 нельзя, либо не увидит, либо зависоны будут. Такая схемотехника корявая, ничего не поделаешь.
19.03.18 в 15:25
0
я брал тфт32... там есть юсб штатная...
буду пробовать дополнительно экранировать кабель...
19.03.18 в 22:05
0
напряжение питания - 12.1 вольт стабильно...

напряжение на пинах нагрва хотэнда - 2.9
смена пина - те-же 2.9 вольт

temperature_control.hotend.max_pwm

какие будут предложения?
19.03.18 в 22:32
0
temperature_control.hotend.max_pwm - 240
19.03.18 в 22:58
0
Max pwm 255 поставить. Или вообще строчку закоментировать для пробы. Светодиоды у мосфетов ярко горят? Сами мосфеты не греются? А то малоли, вдруг работают в линейном режиме изза недооткрытия.
Термистор сам живой? Может он ерунду показывает? Но это врятли, его неисправность скорее раскалит голову.



Я при настройке долго воевал со столом, никак не мог раскочегарить до нужной температуры, пока все эти коэффициенты не подобрал методом тыка.

Завтра могу скинуть свой конфиг, для пробы. Пиши куда выслать.
20.03.18 в 10:03
0
светодиоды горят ярко
мосфеты под одним радиатором - не греются...
термистор живой

2 недели-ж небыло проблем...

и еще... на мосфете вентилятора обдува детали все гуд - 12 вольт...

а три первых - (стол и два нотэнда) 2-9!!!
как такое может быть?
oleg.andreychenko@gmail.com
20.03.18 в 12:50
0
Отправил мой файл. Ставь шим 255.
Почему это произошло хз. Мериешь на голове напряжение? Провод мог перетереться внутри за пару недель. С виду он нормальный, внутри рваный.
20.03.18 в 13:17
0
меряю на пинах на матери... 2.9!
с головой все в порядке. проверял.

вопрос точно где-то в мосфетах... вопрос только в причине...
20.03.18 в 13:22
0
У нас разные дисплеи, у тебя тфт3.2? Этот дисплей умнее sbase, со своим конфигом. Он может тоже слать не те команды, а мы тут голову ломаем.

2.9 это работает шим. А вот почему он работает.. Удали вообще эту строчку из конфига.

Temperature control hotend max temp что стоит? Должно к 300. Это ограничение максимальной температуры

Еще у sbase есть такая хрень, как калибровочные праметры.
temperature_control.hotend.p_factor 33.0
temperature_control.hotend.i_factor 2.284
temperature_control.hotend.d_factor 119

Это мои значения, у тебя будут другие. Как я их получил уже подзабыл, вроде вводил команду через пронтерфейс и принтер сам себя калибровал, полученные значения вводил в конфиг. С не правильными значениями вполне реально зависнуть на низкой температуре, у меня так со столом было.



во, нашел.
M303 E0 S190
примерная команда, e0 это калибровка хотенда.e1 стол. s190 требуемуя температура, ставь 230 примерно. По факту получишь на выходе свои поправочные коэффициенты. Команду вводил в репитер хосте. Принтер к компу по юсб.
20.03.18 в 13:36
0
пиды я настраивал с пронтерфейса под свою голову... у меня свои значения... проблем не было...
максимальная температура хотэнда - закоментирована вообще...
20.03.18 в 13:37
0
сегодня попробую 12864 прицепить - посмотрю, что с ним будет...
20.03.18 в 13:43
0
Обновил пост выше, перечитай.
Максимальную температуру рекомендую раскоментировать и еще настроить параметр нагрева по времени, какая никакая защита от пожара. Если термистор откажет, чтобы 3 минуты грело скажем, а дальше если нет ответа от термистора вырубалось с ошибкой. У меня в конфиге глянь, было такое.
12864 мне нравится, единственное с флешкой и картой не дружит и паузы нет. Но зато он прост, тфт слишком умный и к сожалению с криво написаным кодом. Глюкодром.
Настройки для 12864 опять таки у меня можешь взять, чтобы кнопки работали и енкодер как надо отрабатывал, а иначе он глючить будет.

Как вариант подключить хотенд к разъему стола и врубить режим bang bang. Это очень грубый механиз регулирования, с ним температура будет скакать туда сюда, но отстроить его немного можно и как вариант для проверки хотенда вариант годится.

Для написания комментариев, пожалуйста, авторизуйтесь.